Pages may be slow loading
Incident Report for TrueContext
Resolved
System performance has returned to normal
Posted May 20, 2020 - 10:24 EDT
Monitoring
We have resolved the performance degradation and are monitoring our systems.
Posted May 20, 2020 - 10:14 EDT
Investigating
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible. This will affect all operations, including the administration portal and form submissions.
Posted May 20, 2020 - 10:08 EDT
This incident affected: Admin Console, Form Builder, Mobile App Communications, Document Generation, Scheduled Jobs, and Public REST API.