Marketing Website Down
Incident Report for Prontoforms
Resolved
Functionality has returned to normal
Posted Feb 13, 2020 - 09:40 EST
Monitoring
Marketing website access is returning to normal. We are continuing to monitor access.
Posted Feb 12, 2020 - 16:28 EST
Identified
We have identified an issue with our marketing website, resulting in the website not being accessible. To log in to the admin console, please visit https://live.prontoforms.com/
Posted Feb 12, 2020 - 16:13 EST
This incident affected: Admin Console.