Customer Satisfaction Form Loading Errors
Incident Report for Prontoforms
Resolved
This incident has been resolved.
Posted Mar 08, 2021 - 08:47 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2021 - 08:41 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2021 - 08:30 EST
Investigating
We are currently investigating an issue that impacts filling in Customer Satisfaction Forms.
Posted Mar 08, 2021 - 08:29 EST