Pages may be slow loading
Incident Report for TrueContext
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 14:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2022 - 13:42 EDT
Investigating
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Mar 14, 2022 - 12:55 EDT
This incident affected: Admin Console and Form Builder.