Pages may be slow loading
Incident Report for Prontoforms
Resolved
This incident has been resolved.
Posted May 19, 2021 - 16:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2021 - 16:00 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 19, 2021 - 15:45 EDT
Investigating
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted May 19, 2021 - 15:40 EDT
This incident affected: Admin Console, Mobile App Communications, and Public REST API.