Pages may be slow loading
Incident Report for Prontoforms
Resolved
This incident has been resolved.
Posted Mar 23, 2022 - 13:16 EDT
Monitoring
A fix has been implemented, we are monitoring the results.
Posted Mar 23, 2022 - 12:51 EDT
Investigating
The site is currently experiencing a higher than normal amount of load and maybe causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Mar 23, 2022 - 12:27 EDT
This incident affected: Admin Console and Form Builder.